#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)^<([^>\s]+)[^>]*>(.*)</\1>$"
Local $sString = "<p with="scary<>'"" attrs="40" ok>Hello <em>World</em></p>"
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)