re = /^<([^>\s]+)[^>]*>(.*)<\/\1>$/
str = '<p with="scary<>\'"" attrs="40" ok>Hello <em>World</em></p>'
subst = '$2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result