$re = '@^<([^>\s]+)[^>]*>(.*)</\1>$@s';
$str = '<p with="scary<>\'"" attrs="40" ok>Hello <em>World</em></p>';
$subst = "$2";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;