const regex = new RegExp('^<([^>\\s]+)[^>]*>(.*)</\\1>$', 's')
const str = `<p with="scary<>'"" attrs="40" ok>Hello <em>World</em></p>`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);