import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^<([^>\\s]+)[^>]*>(.*)</\\1>$";
final String string = "<p with=\"scary<>'"\" attrs=\"40\" ok>Hello <em>World</em></p>";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}