use strict;
my $str = '<p with="scary<>\'"" attrs="40" ok>Hello <em>World</em></p>';
my $regex = qr@^<([^>\s]+)[^>]*>(.*)</\1>$@sp;
my $subst = '$2';
my $result = $str =~ s@$regex@$subst@r;
print "The result of the substitution is' $result\n";