using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^<([^>\s]+)[^>]*>(.*)</\1>$";
string substitution = @"$2";
string input = @"<p with=""scary<>'""" attrs=""40"" ok>Hello <em>World</em></p>";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}