package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{2}\.\d{2})(?:.*dollars.*)`)
var str = `78.00600.00 dollars test`
var substitution = "$1 dollars"
fmt.Println(re.ReplaceAllString(str, substitution))
}