const regex = /^(\d{2}\.\d{2})(?:.*dollars.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{2}\\.\\d{2})(?:.*dollars.*)', 'gm')
const str = `78.00600.00 dollars test`;
const subst = `$1 dollars`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);