use strict;
my $str = '78.00600.00 dollars test';
my $regex = qr/^(\d{2}\.\d{2})(?:.*dollars.*)/mp;
my $subst = '$1 dollars';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";