$re = '/^(\d{2}\.\d{2})(?:.*dollars.*)/m';
$str = '78.00600.00 dollars test';
$subst = "$1 dollars";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;