import Foundation
let pattern = #"^(\d{2}\.\d{2})(?:.*dollars.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"78.00600.00 dollars test"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 dollars"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)