// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d{2}\.\d{2})(?:.*dollars.*)").unwrap();
let string = "78.00600.00 dollars test";
let substitution = "$1 dollars";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}