#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:(^|[\s;(])(?!xfa\.resolveNode\(\".+\"\))((?:[a-zA-Z0-9_\.\[\]]*))(\.(?:rawValue|access|fillColor)))"
Local $sString = "if (!scriptobject.isNotariusSigned()) {" & @CRLF & _
" if(form1.subform[1].lkasdfasdfasdf_sfasffsdf.rawValue == "") {" & @CRLF & _
" form1.subform[1].live.sfskljfljflaksjfaksdjfl.rawValue == "1";" & @CRLF & _
" }" & @CRLF & _
"}"
Local $sSubst = "\1xfa.resolveNode\("\2"\)\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)