const regex = /(?:(^|[\s;(])(?!xfa\.resolveNode\(\".+\"\))((?:[a-zA-Z0-9_\.\[\]]*))(\.(?:rawValue|access|fillColor)))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(^|[\\s;(])(?!xfa\\.resolveNode\\(\\".+\\"\\))((?:[a-zA-Z0-9_\\.\\[\\]]*))(\\.(?:rawValue|access|fillColor)))', 'gm')
const str = `if (!scriptobject.isNotariusSigned()) {
if(form1.subform[1].lkasdfasdfasdf_sfasffsdf.rawValue == "") {
form1.subform[1].live.sfskljfljflaksjfaksdjfl.rawValue == "1";
}
}`;
const subst = `\1xfa.resolveNode\("\2"\)\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);