using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(^|[\s;(])(?!xfa\.resolveNode\(\"".+\""\))((?:[a-zA-Z0-9_\.\[\]]*))(\.(?:rawValue|access|fillColor)))";
string substitution = @"\1xfa.resolveNode\(""\2""\)\3";
string input = @"if (!scriptobject.isNotariusSigned()) {
if(form1.subform[1].lkasdfasdfasdf_sfasffsdf.rawValue == "") {
form1.subform[1].live.sfskljfljflaksjfaksdjfl.rawValue == ""1"";
}
}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}