$re = '/(?:(^|[\s;(])(?!xfa\.resolveNode\(\".+\"\))((?:[a-zA-Z0-9_\.\[\]]*))(\.(?:rawValue|access|fillColor)))/m';
$str = 'if (!scriptobject.isNotariusSigned()) {
if(form1.subform[1].lkasdfasdfasdf_sfasffsdf.rawValue == "") {
form1.subform[1].live.sfskljfljflaksjfaksdjfl.rawValue == "1";
}
}';
$subst = "\1xfa.resolveNode\(\"\2\"\)\3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;