import re
regex = re.compile(r"(?:(^|[\s;(])(?!xfa\.resolveNode\(\".+\"\))((?:[a-zA-Z0-9_\.\[\]]*))(\.(?:rawValue|access|fillColor)))", flags=re.MULTILINE)
test_str = ("if (!scriptobject.isNotariusSigned()) {\n"
" if(form1.subform[1].lkasdfasdfasdf_sfasffsdf.rawValue == \"\") {\n"
" form1.subform[1].live.sfskljfljflaksjfaksdjfl.rawValue == \"1\";\n"
" }\n"
"}")
subst = "\\1xfa.resolveNode\\(\"\\2\"\\)\\3"
result = regex.sub(subst, test_str)
if result:
print(result)