use strict;
my $str = 'if (!scriptobject.isNotariusSigned()) {
if(form1.subform[1].lkasdfasdfasdf_sfasffsdf.rawValue == "") {
form1.subform[1].live.sfskljfljflaksjfaksdjfl.rawValue == "1";
}
}';
my $regex = qr/(?:(^|[\s;(])(?!xfa\.resolveNode\(\".+\"\))((?:[a-zA-Z0-9_\.\[\]]*))(\.(?:rawValue|access|fillColor)))/mp;
my $subst = '\\1xfa.resolveNode\\("\\2"\\)\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";