# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=[([]) +| +(?=[)\]])//g;t' <<< "This is ( a sample ) [ string ] to play with
This is ( a sample ) [ string] to play with"