$re = '/(?<=[([]) +| +(?=[)\]])/';
$str = 'This is ( a sample ) [ string ] to play with
This is ( a sample ) [ string] to play with';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;