#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=[([]) +| +(?=[)\]])"
Local $sString = "This is ( a sample ) [ string ] to play with" & @CRLF & _
"This is ( a sample ) [ string] to play with"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)