using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[([]) +| +(?=[)\]])";
string substitution = @"";
string input = @"This is ( a sample ) [ string ] to play with
This is ( a sample ) [ string] to play with";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}