import re
regex = re.compile(r"(?<=[([]) +| +(?=[)\]])")
test_str = ("This is ( a sample ) [ string ] to play with\n"
"This is ( a sample ) [ string] to play with")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)