const regex = /(?<=[([]) +| +(?=[)\]])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[([]) +| +(?=[)\\]])', 'g')
const str = `This is ( a sample ) [ string ] to play with
This is ( a sample ) [ string] to play with`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);