#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(2019\/10\/|2019\/11\/|2019\/12\/|2019-10-|2019-11-|2019-12-)"
Local $sString = "2019/11/25 " & @CRLF & _
"2018-12-01 " & @CRLF & _
"2019/08/10" & @CRLF & _
"2018/10/02"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")