import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(2019\\/10\\/|2019\\/11\\/|2019\\/12\\/|2019-10-|2019-11-|2019-12-)";
final String string = "2019/11/25 \n"
+ "2018-12-01 \n"
+ "2019/08/10\n"
+ "2018/10/02";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}