// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(2019\/10\/|2019\/11\/|2019\/12\/|2019-10-|2019-11-|2019-12-)").unwrap();
let string = "2019/11/25
2018-12-01
2019/08/10
2018/10/02";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}