use strict;
my $str = '2019/11/25
2018-12-01
2019/08/10
2018/10/02';
my $regex = qr/(2019\/10\/|2019\/11\/|2019\/12\/|2019-10-|2019-11-|2019-12-)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}