$re = '/(2019\/10\/|2019\/11\/|2019\/12\/|2019-10-|2019-11-|2019-12-)/m';
$str = '2019/11/25
2018-12-01
2019/08/10
2018/10/02';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);