package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(2019\/10\/|2019\/11\/|2019\/12\/|2019-10-|2019-11-|2019-12-)`)
var str = `2019/11/25
2018-12-01
2019/08/10
2018/10/02`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}