const regex = /(2019\/10\/|2019\/11\/|2019\/12\/|2019-10-|2019-11-|2019-12-)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(2019\\\/10\\\/|2019\\\/11\\\/|2019\\\/12\\\/|2019-10-|2019-11-|2019-12-)', 'gm')
const str = `2019/11/25
2018-12-01
2019/08/10
2018/10/02`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}