# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+|[-.;?!,:])/$1/gsix;t' <<< "However, I now have words like these:
Word-another-word
more_words_like_these
and I would like to be able to retain the integrity of these words as they are (connected) but my current preg_match breaks them down into individual words."