import Foundation
let pattern = #"(\w+|[-.;?!,:])"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.caseInsensitive, .allowCommentsAndWhitespace, .dotMatchesLineSeparators])
let testString = #"""
However, I now have words like these:
Word-another-word
more_words_like_these
and I would like to be able to retain the integrity of these words as they are (connected) but my current preg_match breaks them down into individual words.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)