#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?six)(\w+|[-.;?!,:])"
Local $sString = "However, I now have words like these:" & @CRLF & _
"" & @CRLF & _
"Word-another-word" & @CRLF & _
"more_words_like_these" & @CRLF & _
"" & @CRLF & _
"and I would like to be able to retain the integrity of these words as they are (connected) but my current preg_match breaks them down into individual words."
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)