const regex = /(\w+|[-.;?!,:])/gsi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w+|[-.;?!,:])', 'gsi')
const str = `However, I now have words like these:
Word-another-word
more_words_like_these
and I would like to be able to retain the integrity of these words as they are (connected) but my current preg_match breaks them down into individual words.`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);