import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w+|[-.;?!,:])";
final String string = "However, I now have words like these:\n\n"
+ "Word-another-word\n"
+ "more_words_like_these\n\n"
+ "and I would like to be able to retain the integrity of these words as they are (connected) but my current preg_match breaks them down into individual words.";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}