package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?si)(\w+|[-.;?!,:])`)
var str = `However, I now have words like these:
Word-another-word
more_words_like_these
and I would like to be able to retain the integrity of these words as they are (connected) but my current preg_match breaks them down into individual words.`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}