#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!\S)(\*{2}|[_`])|(\*{2}|[_`])(?!\S)"
Local $sString = "The next line is **" & @CRLF & _
"" & @CRLF & _
"_This line surrounded with emphasis mark_" & @CRLF & _
"" & @CRLF & _
"`hey this is crazy`" & @CRLF & _
"" & @CRLF & _
"**bold**"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")