import re
regex = re.compile(r"(?<!\S)(\*{2}|[_`])|(\*{2}|[_`])(?!\S)")
test_str = ("The next line is **\n\n"
"_This line surrounded with emphasis mark_\n\n"
"`hey this is crazy`\n\n"
"**bold**")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")