import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\S)(\\*{2}|[_`])|(\\*{2}|[_`])(?!\\S)";
final String string = "The next line is **\n\n"
+ "_This line surrounded with emphasis mark_\n\n"
+ "`hey this is crazy`\n\n"
+ "**bold**";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}