$re = '/(?<!\S)(\*{2}|[_`])|(\*{2}|[_`])(?!\S)/';
$str = 'The next line is **
_This line surrounded with emphasis mark_
`hey this is crazy`
**bold**';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);