const regex = /(?<!\S)(\*{2}|[_`])|(\*{2}|[_`])(?!\S)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\S)(\\*{2}|[_`])|(\\*{2}|[_`])(?!\\S)', 'g')
const str = `The next line is **
_This line surrounded with emphasis mark_
\`hey this is crazy\`
**bold**`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}