using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)(\*{2}|[_`])|(\*{2}|[_`])(?!\S)";
string input = @"The next line is **
_This line surrounded with emphasis mark_
`hey this is crazy`
**bold**";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}