re = /(?<!\S)(\*{2}|[_`])|(\*{2}|[_`])(?!\S)/
str = 'The next line is **
_This line surrounded with emphasis mark_
`hey this is crazy`
**bold**'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end