#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "h+i+k+e+"
Local $sString = "I am looking for simple way to have catch variant of word like" & @CRLF & _
"" & @CRLF & _
"hike hhike hiike hikke hikkee" & @CRLF & _
"" & @CRLF & _
"Using something similar to the format below..." & @CRLF & _
"" & @CRLF & _
"[([a-zA-Z]){4,}]" & @CRLF & _
"" & @CRLF & _
"Thanks"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")