re = /h+i+k+e+/
str = 'I am looking for simple way to have catch variant of word like
hike hhike hiike hikke hikkee
Using something similar to the format below...
[([a-zA-Z]){4,}]
Thanks'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end