using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"h+i+k+e+";
string input = @"I am looking for simple way to have catch variant of word like
hike hhike hiike hikke hikkee
Using something similar to the format below...
[([a-zA-Z]){4,}]
Thanks";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}