import re
regex = re.compile(r"h+i+k+e+")
test_str = ("I am looking for simple way to have catch variant of word like\n\n"
"hike hhike hiike hikke hikkee\n\n"
"Using something similar to the format below...\n\n"
"[([a-zA-Z]){4,}]\n\n"
"Thanks")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")