$re = '/h+i+k+e+/';
$str = 'I am looking for simple way to have catch variant of word like
hike hhike hiike hikke hikkee
Using something similar to the format below...
[([a-zA-Z]){4,}]
Thanks';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);